A little while ago, I needed to change my MAC address on the OpenBSD firewall I’ve got running. (My ISP kept feeding me a bad IP address from an old lease and I wanted a new one.)
It’s easy to do this on OpenBSD:
ifconfig vr1 down ifconfig vr1 lladdr 00:11:22:33:44:55 ifconfig vr1 up
The question is, where’s the right place to put this to make it permanent? A few web searches revealed that a bunch of people had modified /etc/netstart by putting the ifconfig vr1 lladdr line somewhere near the beginning. I’d rather not sully my pristine /etc scripts with changes if I don’t have to.
Linux has /etc/network/interfaces, and OpenBSD has /etc/hostname.if. I just changed my /etc/hostname.vr1 to:
dhcp lladdr 00:11:22:33:44:55
and I was requesting an IP address using my new MAC address.